Fixing VM’s Network Disconnect Issue in VMware Workstation

I had been trying VMware Workstation for quite a bit and when the evaluation period ran out I decided to buy the license for it as I am quite happy about the features that are existed in free version of VMware Player. But after I bought the license and registered my evaluation copy, all my VMs that ran fine before had a network connection issue. None of them show connected when booted up.

All these VMs have network adapter set to use as Bridged mode, pretending connecting directly to the physical network. But when I went into Virtual Network Editor from Edit menu, I didn’t see a Bridged type of connection available in the list. And it kept telling me it’s unavailable when I tried to manually add it.

What I did that actually fixed this issue is to simply press that Restore Default button at the bottom left corner in Virtual Network Editor. It took about a minute to reset all network settings. And when it’s finished, the VMnet0 set as Bridged type miraculously returned.

Virtual Network Editor 2013 10 22 15 32 04 - Fixing VM's Network Disconnect Issue in VMware Workstation
VMware Workstation – Virtual Network Editor

3 thoughts on “Fixing VM’s Network Disconnect Issue in VMware Workstation

  1. Thank you very much. This got me out of a pickle today and meant I didn’t have to drive in to work, for which I’m unbelievably grateful.

    Much appreciated

    Adam

Leave a Reply to Chimmu Jhulewla Cancel reply

Your email address will not be published. Required fields are marked *